Skip to main content

起步

简要介绍 Bootstrap,以及如何下载、使用,还有基本模版和案例,等等。

--本章内容翻译由:樊潇洁友情提供

下载

Bootstrap v4.0.0-alpha有以下几种可用的下载方式,包括你们最喜欢的包管理工具。任选下面的选项下载你所需要的。

编译版本

下载这个精简过的CSS和JavaScript编译版本。它不包括任何文档和原始的源代码文件。

敬请期待

源代码文件

下载包包括:源代码Sass、JavaScript和文档文件。你需要一个Sass编译器, 自动预制器,以及其它安装设置.

下载源码

包管理工具

用一些流行的包管理器可以把Bootstrap的源文件插入到几乎所有的工程项目中。无论用哪种管理器,Bootstrap要求一个Sass编译器和自动预制器**来进行安装,以配置官方的编译版本。

请注意! 目前并非所有的包管理器都有这个刚发布的v4 alpha版本,但是我们不久即将普及它。

Bower

请使用Bower安装和管理Bootstrap的Sass和JavaScript。

$ bower install bootstrap

npm

请用npm安装包在你的Node应用中安装Bootstrap:

$ npm install bootstrap

require('bootstrap')将会在jQuery对象上加载所有的Bootstrap的jQuery插件。bootstrap模块不会导出任何东西。你可以通过逐个载入包装包中顶级目录下的/js/*.js文件,手动加载Bootstrap的jQuery插件。

Bootstrap的package包在下面这些键中包含了一些额外的元数据:

  • sass ——Bootstrap的主要的Sass源文件的路径。
  • style ——Bootstrap的没有缩小过的CSS文件的路径,该CSS文件使用默认设置预编译(非自定义预编译)。

Meteor

$ meteor add twbs:bootstrap

Composer

你还可以使用Composer安装并且管理Bootstrap的Sass的JavaScript:

$ composer require twbs/bootstrap

自定义构建

你只需要Bootstrap的CSS或JS的一部分?请用自定义构建来获得你想要的。

重启

包括variables/mixins、Normalize以及Reboot,但是没有JavaScript。

下载

Grid only

包括variables/mixins以及grid系统,但是没有JavaScript。

下载

Flexbox

所有的Bootstrap的弹性盒都可用,而且支持较低版本的浏览器

下载